zaurus用 GW-CF54G ドライバ完成!

ついに、zaurus 用の Planex GW-CF54G ドライバができました!!
ダウンロードはダウンロードページへ。

—–追記ここから——

期待させてしまって申し訳ないですが、SL-Cxx0の3桁機は現状では動作しません。また、4桁機でも SL-C1000でしか確認が取れていません。人柱バージョンとお考えください。
(追記の追記: その後 SL-C3000,3200 でも動作した方がいらっしゃいました。ご報告ありがとうございます!)

試してみた方は、動いても動かなくても、ご報告いただけると完成度が高まる可能性があります。
問題があっても対応できないこともありますが、動作するケース/動作しないケースが切り分けられるだけでもとても有意義な情報になります。

匿名でも構いませんので、是非ともご報告お待ちしております!

追記の追記

おかげさまで多くの動作報告を頂きました。ご協力ありがとうございました。
全機種分の報告も頂けましたし、実績は十分と判断しまして、このバージョンについては不具合があったときにご報告頂ければと思います。

ご協力いただいた皆様ありがとうございました!!

—–追記ここまで——

GW-CF54Gで無線LAN接続!!
GW-CF54Gで無線LAN接続!!

他の無線LANカード同様、「ネットワーク設定」で設定した無線LAN設定を使って接続できます。

WEPがかかったアクセスポイントに接続できることは確認しましたが、すべてのケースを試したわけではないので、繋がらない条件もあるかもしれません。

その時はコメントいただければ対応できる可能性があります。(対応できない場合もあります)

 

このドライバは、Gumstixのサイトにあったソースを元に、強引にサスペンド・レジュームに対応させたものです。

前回の日記にも書きましたが、zaurus はカードを挿した後、接続するまでサスペンドします。ですが、元のドライバはサスペンドレジュームに対応していませんでした。

チップの詳しい仕様も分からず(特に調べてないですが)なので、一番手っ取り早く、サスペンド時にドライバのアンロード時の処理を実行し、レジューム時にドライバロード時の処理を実行するようにしました。

ただ、サスペンド時にネットワークデバイス(wlan0)まで消してしまうと、Qtopia的にはカードが抜けたときと同じ扱いになってしまうようで、レジュームしてもカードを挿したとき同様すぐサスペンドしてしまいます。

そのため、サスペンド時はネットワークデバイスは残したまま他のリソースはすべて開放し、レジューム時はネットワークデバイス登録以外の初期化処理を行うことで、無理やりサスペンド/レジュームに対応させています。

そんなわけで、だいぶ場当たり的にサスペンドレジュームを実装したため、ちょっと不安定だったりするかもしれません。
実用に耐えるかどうか分かりませんが、とりあえず公開します。人柱になっていただける奇特な方大募集・・・ ^^;

使えないなら使えない旨をコメントいただければ、もしかしたら修正できるかもしれませんので、使ってみた方々の感想をお待ちしています。

関連した記事:


62 comments

  1. bucchi さま、動作報告です。
    私も SL-C1000ですが、自宅の無線LANへの接続が出来ました。このコメントもGW-CF54Gを通して書き込んでいます。

    2週間前にAmazonでこのCFカードを買った際、よもやこんなに早く使える日が来ようとは思ってもいませんでした。
    お陰様で、1580円の宝くじは大当たりです。
    1980円に上昇したAmazonの価格、これでまた上がるかもしれませんね!

    このカードの消費電力仕様はMax1.6Wとなっていますが、使って見ると結構熱くなりますね。ちなみに放射赤外温度計で測定したところ、表面で43℃、裏面で44℃まで行ってました。この熱、Marvellのchipsetだけでなく眩しく輝く青と橙のLEDも一役買っているのかも(^^;

    • 早速動作確認頂きありがとうございます。
      ひとまず一人でも動作した方がいてよかったです ^^;

      ちなみに無線LANの環境はどのような設定になっていますでしょうか?
      zaurus で無線 LAN を使う方は WEP(128bit) が多いかなと思いますが・・・。
      動作した条件と動作しない条件をまとめようと思いますので、教えていただけるとうれしいです。

      熱については気づいていませんでしたが、結構熱くなっているんですね。
      それにしても放射赤外温度計を持っているなんて、そっちに驚きです ^^
      確かにこのカードの LED、無駄に眩しいですよね。

      • 設定は従来のままで接続できました。
        具体的には以下になります。
        ・基本設定:ESS-IDを指定 する
        ・暗号化:WEP 104bit(128bit),文字設定,Open System
        ・PPPoE:PPPoEを使用 しない
        ・Web認証:Web認証を使用 しない
        ・TCP/IP:IPアドレスを自動的に取得 する
        ・DNS:ネームサーバの自動検出 する
        ・プロキシ:プロキシを使用しない

        放射赤外温度計ですが、最近は料理用とかペットの体温測定用として安く売っていますよ。私が使っているのはオーム電機製のTN103で、Amazonで3000円程度でした。精度が下がりますが2000円未満のTN006もあるようです。
        きっかけはハンダゴテのコテ先温度測定用だったのですが、最近はお茶、味噌汁、ご飯、ジュース、お酒、耳の中等、何でもかんでも測定して面白がってます。夜空に向けると雲が無ければ-10度とかになります。上空の寒気の温度なのか宇宙の温度なのかは判りませんが、とにかく興味深いです。

          • 先にコメントいただいていたのに、すっかり返信が遅くなってしまい、大変失礼いたしました。
            無線LANの設定教えて頂きありがとうございます。ダウンロードページにまとめようと思います。

            SL-C1000 といい、WEP(128bit)といい、スペカといい、私とまったく同じ状況だったので動作したのでしょうね。
            大見栄切って「ドライバ完成!」とか銘打っておいて誰一人動作しなかったらシャレにならなかったので、sugarware さまの動作報告があってほんとよかったです。

            あ、放射赤外温度計ってそんなに身近で手軽なものなのですね。
            ハードに精通した sugarware さまなので、何か仕事で使うような (?) スピードガンのような工業用のすごいものを想像していました (^^;

            夜空の温度が -10 度というのは面白いですね。何の温度なんだろうとか、宇宙は真空だから温度は無い?とか、赤外線温度計ということは可視光で言う照度計(?)だろうから・・・とか色々想像をして、ちょっと新鮮でした (^^)
            身近な科学に思いを巡らせるのも楽しいですね!

  2. bucchiさん

    ドライバー開発お疲れ様です。
    sugarwareさん同様、GW-CF54Gを保険で買っておいたので早速試してみました。

    まず、SL-C3000。
    地球アイコンは表示されますが、接続できず。
    カードの電源ランプが点灯していません。

    次、SL-C860。
    こちらは地球アイコンが表示されません。

    とりあえず、出勤前なのでここまで。

    また詳細を報告します。

    • まず、C3000から。
      SL-C3000 スペカv18j

      # cardctl status
      Socket 0:
      3.3V 16-bit PC Card [suspended]
      Socket 1:
      3.3V 16-bit PC Card
      function 0: [ready], [bat dead], [bat low]
      # cardctl config
      Socket 0:
      Vcc 0.0V Vpp1 0.0V Vpp2 0.0V
      Socket 1:
      Vcc 3.3V Vpp1 0.0V Vpp2 0.0V
      interface type is “memory and I/O”
      irq 136 [exclusive] [level]
      function 0:
      config base 0x0200
      option 0x41 status 0x00 pin 0x00 copy 0x00
      io 0xf7000000-0xf700000f [auto]
      #

      続いてC860
      SL-C860 スペカv14i

      # cardctl status
      Socket 0:
      3.3V 16-bit PC Card
      function 0: [ready]
      Socket 1:
      no card
      # cardctl config
      Socket 0:
      Vcc 3.3V Vpp1 3.3V Vpp2 3.3V
      Socket 1:
      not configured
      #

      あと、SL-C760でもやってみましたが、C860と同じ結果でした。

      以上追加情報でした。
      では仕事に行ってきます。

      • 出勤前の忙しい時間にありがとうございます m(_ _)m
        SL-C3000 はこちらと同じですね。
        SL-C860 は suspend していないんですね。
        あ、ドライバがロードされていないから当然か。

        と、ふと気づいたんですが、3桁機と4桁機ではカーネルバージョンて違うのかもしれないですね。
        となると、ドライバモジュールをインストールする場所が変わるので、
        それでドライバがロードされていないのかもしれません。
        もうちょっと調べてみます。

        • 3桁機のカーネルバージョンは 2.4.18 なんですね。
          2.4.18 用にコンパイルすれば3桁機でも使えるかな・・?

          SL-C3000 の方はまだよくわからないです・・

          • 今使っているC3000はいろいろといじくりすぎているので、こちらの問題かも。
            載せ代えで外した素のマイクロドライブがあるので、交換して試してみます。

            では。

          • 素のC3000で確認してみました。
            結果は変わらず地球アイコンは表示されますが、接続できませんでした。
            電源LEDですが、まったく点灯しません。
            動作としては、「初期化中」のまま先に進みません。
            ある程度時間が経つと「接続されていません」となって終了します。

            C1000とC3X00では同じようで違うところがけっこーあるようですね。

          • わざわざマイクロドライブの交換までしていただいて、本当にありがとうございます。
            地球アイコンまで出ているということは、初期化スクリプトがおかしいのかな・・・
            申し訳ないのですが、以下のコマンドを実行してみていただけますか?

            $ diff -u /etc/pcmcia/wlan-ng.cf8385bak /etc/pcmcia/wlan-ng

            .cf8385bak がついている方が元々入っていた wlan-ng スクリプトで、拡張子なしの方がドライバインストールで差し替えた後のスクリプトです。

            SL-C1000 の場合はこんな感じです。
            — /etc/pcmcia/wlan-ng.cf8385bak Fri Nov 7 22:15:53 2008
            +++ /etc/pcmcia/wlan-ng Thu Nov 6 15:15:12 2008
            @@ -80,6 +80,12 @@
            # ACTION=$1 and DEVICE=$2 are assigned in pcmcia/shared
            if [ -f /etc/pcmcia/shared ] ; then . /etc/pcmcia/shared ; fi

            +get_info $DEVICE
            +if [ “$DRIVER” = “mcf25” ]; then
            + . /etc/pcmcia/mcf
            + exit 0
            +fi
            +
            # XXXX we can do stuff with $SCHEME still..?
            case “$ACTION” in

            SL-C3000 と SL-C1000 でここはほとんど変わらないだろうと思って SL-C1000 のスクリプトをベースに修正してしまったので、それが原因で動作しないのかもしれません。

            あまりに差分が多くて張り付けるのが大変な場合は、差分が多かったということだけでも結構ですので教えていただけるとありがたいです。

          • 今の状態じゃ動かないことが分かりました・・・。
            linux-2.4.18 向けにコンパイルしようとした所、iw_handler という Wireless Extention 向けの便利な機能が 2.4.18 には入っていないことが分かりました。

            このドライバは iw_handler を使って実装してあるので、iw_handler 相当を 2.4.18 にバックポートするか、iw_handler を使わない実装に戻さないとコンパイルすらできません・・・。

            ということで SL-C860 はちょっと置いておいてください。
            なんとか対応できないか調べてみます。

          • いろいろ検討いただきありがとうございます。

            で、差分です。

            — /etc/pcmcia/wlan-ng.cf8385bak Wed Jun 23 20:31:48 2004
            +++ /etc/pcmcia/wlan-ng Thu Nov 6 08:00:32 2008
            @@ -44,7 +44,6 @@
            #
            # ——————————————————————–


            # [MSM]: Moved here because wlan/shared may is intended to be used by
            # other scripts
            wlan_usage ()
            @@ -80,6 +79,12 @@
            # Note: this ‘shared’ comes with the PCMCIA package
            # ACTION=$1 and DEVICE=$2 are assigned in pcmcia/shared
            if [ -f /etc/pcmcia/shared ] ; then . /etc/pcmcia/shared ; fi
            +
            +get_info $DEVICE
            +if [ “$DRIVER” = “mcf25” ]; then
            + . /etc/pcmcia/mcf
            + exit 0
            +fi

            # XXXX we can do stuff with $SCHEME still..?
            case “$ACTION” in

            自分にはチンプンカンプンですが、若干違う程度のようです。

            > ということで SL-C860 はちょっと置いておいてください。
            > なんとか対応できないか調べてみます。
            いえいえ、SL-C860はすでに現役ではないので気が向いたらでかまいません。

          • ご確認ありがとうございます。
            特に問題になる差はないですね・・・。
            うーん、どうしてだろう・・・。
            スロット数の違いで何かのスクリプトが変わっているのかなぁ?

            できるだけお手間をかけさせないような切り分け方法を考えてみますので、もうしばらく考えさせてください。
            うーん。。。

          • いろいろご検討いただいてありがとうございます。

            無線LANカードは他にも所有しているので、GW-CF54Gは使用中のカードが壊れた時の「保険」として買っておいたもです。

            ですので、気が向いたときにでも検討いただければと思います。
            いろいろとありがとうございます。

    • こんなに早く 2 人も試していただけるとは思っていなったので、ちょっと驚きです。ありがたや・・・

      SL-C3000 は SL-C1000 とほぼ同じなので動くと思ったのですが・・。
      接続時に LED がチカチカすることもないでしょうか?
      正常接続時は、数回 LED がチカチカ点滅した後、0.5〜1秒くらい消灯し、連続点灯になります。
      接続できない場合もチカチカはするはずなので、この有無を教えてください。

      SL-C860 は地球アイコンすら表示されないのですね。
      ということはドライバがロードできていないということ。
      4桁機と仕組みが違うのでしょうかね・・・。
      CPUは違えどドライバは同一のものが使えると思うのですが。
      どうすれば調べられるかちょっと考えてみます。

  3. SL-C3200にて、待望のドライバーを入れ確認を
    行いました。そのままの設定にて接続OKでした。
    但し、クオルティの表示はしませんでしたが接続は出来ました。

    • はじめまして。 gunta 様

      iwconfig で確認した所、確かに Link Quality が 0/0 ですね。
      Signal level や Noise level は得られているので、表示できてもよさそうですが・・・。

      チップの仕様を分かってないので、対応できるか分かりませんが、見るだけ見てみますね。
      ひとまず動作してよかったです。
      ご報告ありがとうございました!

  4. はじめまして。
    こちらのドライバ公開を知り早速使用させていただきました。
    当方の環境SL-C3000ですが何の問題も無く接続できました。
    ・SL-C3000(SpecialKernel v18i <- not v18j) ・SSID指定 ・WEP暗号化(104bit)

      • hake 様、はじめまして。

        ブログでもご紹介頂きありがとうございます!
        しかも、記事を読まれてから購入されたとか・・・動いてよかったです (^^;
        初の SL-C3000 での動作報告になり、ちょっと安心しました。
        ただ、動作する/しないの差もあることが分かったので何とかしないと・・・。

        わざわざカーネルも入れ替えて確認して頂きありがとうございました m(_ _)m
        動作確認表に追加させていただきます。
        ありがとうございました!

  5. 早速、件のカードを入手して試してみました。
    すばらしい・・・すばらしすぎます。
    SL-C3200の動作報告が上がっているので、
    3100の報告は意味がないかもしれませんが嬉しいのでご報告です。

    SL-C3100 
    スペシャルカーネルv18j
    SSID指定、WEP128bit

    上記で接続確認できました。

    • reto. 様、はじめまして。

      おぉ!ついに SL-C3100 の動作報告が!
      意味が無いなんてどんでもない!
      SL-C3100を持っていない私にとっては SL-C3100 でも動作したという情報はとても意味のある実績になります。
      ご報告ありがとうございます!
      動作実績の表に追加させていただきますね。

  6. 初めまして。
    スペカ(v18j)導入のSL-C3100で動作しましたのでご報告を。
    おかげさまで高速なブラウジングを楽しんでおります。

    • はじめまして。
      なるほど、私は意識していなかったのですが、今までのカードに比べ、確かに 802.11g になって高速になっているんですね。
      喜んでいただいてなによりです (^^)
      動作報告ありがとうございました!

  7. こんちは。はじめまして。
    ここの記事を拝見しまして、Amazonで¥1980でポチりました。

    I/OデータのWN-B11/CFで使用してた設定で問題無く接続できています。
    C1000+スペカ18iです。

    I/Oのより数ミリ出っ張るようになりましたけど、カード自体が薄くなっているのでモバイルにはGW-CF54Gの方が向いてるかもしれないですね。
    LEDが元気すぎるのが笑えました。

    レジューム時の自動再接続は出来なくなりましたけど、なにより伝送距離が伸びたのが嬉しいですね。APが2階の書斎に置いてあるんで、1階でネットするときはステータスが赤だったり黄色だったりで不安定でした。カード自体がそろそろ寿命なのかもしれないですが…。GW-CF54Gではばっちり青で接続できています。

    あとはやはりカードの入手性ですね。この値段で買えるのは今後発売される希望が薄い種類のアイテムなんで大きいです。もう一つ買おうかな…。

    長くなりましたけど、これでまたZaurus君、延命できそうで嬉しいです。
    bucchiさんにはホント感謝です。ありがとうございました。

    • はじめまして、えりお様
      動作報告ありがとうございます。
      喜んでいただけたようで、私も嬉しいです。
      エンジニア冥利につきますね(^^)

      > GW-CF54Gではばっちり青で接続できています。
      あ、これは Link Quality が取れていないからかもしれません。

      Qtopia が色分けを何で判断してるのかが分からないので、何ともいえないですが、今のドライバでは繋がっていれば常に青の可能性があります。
      この辺はチップの仕様が分からないと修正できないかもしれないので、直せるかは分からないですが、時間ができたら見てみます。

      GW-CF54G の入手性の高さと値段の安さは、寒風吹きすさぶ zaurus 業界にはまさに救世主的な製品ですよね。

      えりお様も結構 zaurus をいじり倒しているようですが、zaurus はまだまだ現役を退くのはもったいない、面白いハードなので、みんなでガンガンいじり倒しましょう!^^

      • 確かにネットワーク設定の接続の状態を見るとクオリティーは常に0%ですね。でもタスクバーのアイコンは緑の時もあるので電波強度の方を見てるのかと思われます。
        qtopia1.5.0のソースを斜め読みしてみましたけど、電波強度を色で表示するのはシャープ実装のようで、該当部分は見つけられませんでした。残念。

        • 確認していただいて、ありがとうございます。

          qtopia のソースをざっくり斜め読みできるってすごいですね!
          色が常に青というのはちょっと不便なので対応しないとですね。。
          私はまだ時間が取れてなくて調べられてないです・・・
          もうしばらくお待ちください。

  8. SL-C3200 Special Kernel v18j です。
    WL1100C-CF の代わりに付けてみました。

    今までの設定でなんの変更もなく、動作しました。
    もう一個ぐらい買っておこうかなと思案中

    ありがとうございました。

    • はじめまして、かんたろー様
      ちゃんと動作しているようで安心しました。
      これだけ皆さんの zaurus で動作しているので、もう実績は充分ですね。
      ご報告ありがとうございました!

  9. はじめまして。
    私もアマゾンでGW-CF54Gを購入して使ってみました!

    リナザウの無線LANカードはこれが初なので、設定に戸惑いましたが、うまく接続できました。
    これで快適にリナザウでネットをたのしめます!

    本当にありがとうございます!

    ちなみに私は SL-C3200 で、スペカはv18i です。

    • あさりのみそしる様、はじめまして。

      ブログで取り上げていただきありがとうございました。
      qgmap のときも早い段階で紹介してくださっていたので、ちょこちょこブログを拝見させていただいてました。

      CF の無線 LAN カードがこの値段で買えるとは、ちょっと前では考えられないですよね。
      まだまだ zaurus は現役ですので、どんどん使っていきましょう!

  10. はじめましてざうるす@管理人と申します。

    まさかまさかと思い、ドライバーをダウンロードさせていただきました。問題なく動作しています。

    ちなみに環境は
    C3100@スペカv18j + WN-G54/CFです。

    いや!最高ですね!。
    ありがとうございました。

    • ざうるす@管理人様、はじめまして。

      WN-G54/CF の動作報告ありがとうございます。
      ブログも拝見させていただきました。取り上げていただきありがとうございます!

      WN-G54/CF の動作報告はこれで 2人目ですね。問題なく動いているようで、VenderID, DeviceIDも同じということは、やっぱり中身は一緒なんですね。
      胸を張って WN-G54/CF も使えます!と言っても良いかもしれないですね (^^)
      ありがとうございました!

  11. 素晴らしいドライバありがとうございます。
    念のために買っておいたWN-G54/CFとGW-CF54Gがあり、
    なんとZaurusで動くとの情報を今更知った次第です。

    WN-G54/CF、GW-CF54Gにて動作確認しました。
    環境はC1000(スペカv18j)、C860(スペカv14i)です。
    イモバ機を無線モデムにしてのアドホック接続をしています。アドエス、WinXPでのアドホック接続も確認しました。

    • GW-CF54G, WN-G54/CF のどちらもお持ちなのですね。
      動作したようでなによりです (^^)
      イーモバイル端末経由でどこでもネットですか。快適そうですね〜
      私は未だに bitWarp です・・。
      快適なザウルスライフを!

  12. はじめまして、C1000にこのドライバ使わせてもらい、WN-G54/CF動作しました。K30225を使ってネット接続をしていたのですが、壊れて次を物色している最中に、非常に貴重なものをありがとうございます。

    • 問題なく使えているようで、なによりです (^^)
      K30225 よりも通信速度が早くなるので、いくぶんか快適になったかと思います。
      トラックバック、ブログでのご紹介ありがとうございました。
      まだまだ zaurus 使い倒していきましょう!

  13. はじめまして。
    Zaurus SL-C1000とWN-G54/CFですんなり使えました。
    このCFカードで使えるドライバーを以前から探してました。

    早速、インストールして接続しましたら、自宅の無線LANで
    さくさくとブラウジングができるようになりました。
    Zaurusの使える環境が強化できてとてもうれしいです。

    ほんとうにありがたいドライバーを作っていただきまして
    ありがとうございます。

    • 返信が遅くなってごめんなさい。
      喜んでいただけてなによりです (^^)
      11g になるだけで体感で分かるくらい快適になりますよね。
      ネットワークが満足に使えれば zaurus もネットブック相当の事はできますからね。
      どんどん使っていきましょう!

  14. C3000スペカv18jにWN-G54/CF&WPAドライバで便利に使わせて貰っています。
    普段は普通に使えるのですが、Zaurus本体のサスペンド、レジューム(画面を閉じて開く)後に接続できなくなります。
    それも再接続すればつながるのではなく、何回も繰り返したり再起動してやっと繋がります。
    繋がらないときは、「初期化中」が続き、「接続していません」になります。それをホストのAirStation側のクライアントモニターで見てみると、接続と認証、IPアドレスの割り当てまでクリアしているのですが、なぜか初期化中が続き、結局切断してしまいます。
    繋がらないと思ったら突然繋がったりと、繋がるきっかけも不明です。
    これがドライバ側の影響なのか、それともLinux側なのか
    調べてみるとレジューム後に自動で再接続するスクリプトなどもあったので、それも試してみますが、接続が出来ているにもかかわらず初期化中が続くことに関して何かヒントがあれば教えてもらえたら嬉しいです。

    • 返信遅くなってすいません。
      レジューム後に通信できなくなるのは体験してないですね。
      これは接続したままサスペンド・レジュームすると通信できなくなるということでしょうか?
      それとも切断した後にサスレスしても通信できないということでしょうか。
      いずれにしてもちょっと原因は思いつかないんですけどね・・。

      AP側ではDHCPでIPを払い出していることから、WEPやWPAの認証は通っているということですね。しかし zaurus 側で IP が設定できていない。
      であれば、とりあえずの回避策として、固定IPで指定すればすぐ接続できるようになるのではないかと思います。

      • いろいろ弄くった結果、原因が(多分)判明しました。
        wpa_supplicantの問題でしたが、こちらに報告しておきます。
        通常の方法で接続を切断した場合は、wpa_supplicantは通常どおり終了していたのですが、サスペンドなどで切断されていた場合はwpa_supplicantが終了していませんでした。
        そのため、レジュームした際の再接続でwpa_supplicantが多重に動作し、なんらかの干渉が起こっていたのではないかと考えています。
        qtのソースは読めないので的外れなことを言っているかもしれませんが、切断後に起動しているwpa_supplicantをkillすると問題なく接続できるようになりましたのでこれかなと。
        wpa_supplicantを起動する際に重複起動をチェックするようにすれば解決するのではと思うのですが、どうでしょうか?

        • 調べていただいてありがとうございます。

          なるほど。接続中にサスペンドすると切断処理が通常と異なるんですね。
          これは接続スクリプトの問題なので、私のパッケージの問題ですね。
          NoiR さんのおっしゃるとおり、再接続時に wpa_supplicant がいたら kill する処理を入れればよさそうです。

          週末にでも試してみますので、少々お待ちください。

          • 週末は風邪でダウンしていたので、さきほどちょっと試してみました。
            数回試してみたんですが、私の SL-C1000 では接続したまま電源を切るとたまにフリーズしてしまうようです。

            毎回ではないのですが、無線LANカードの LED は消えているのに接続中表示で「電波が弱くなっています」のメッセージが出たりと、ちょっとシステム的によろしくない状態になってしまうようです。

            症状を見た感じでは、ドライバのサスペンド処理が行われる前に電源が落ちてしまって、ドライバとカードの状態不一致を起こしているように思います。まじめにドライバを見直さないとダメそうです。

            NoiRさんの zaurus ではこのような症状はありませんでしょうか?
            スクリプトだけ直すことはできるのですが、このような状態では「接続中の電源断に対応」とは謳えないので、リリースはちょっとできない状態です。

            一応、接続時に wpa_supplicant が起動していたら終了するための、スクリプトの修正位置を記しますので、試してみてください。

            /etc/pcmcia/wpa_script の 10 行目付近
            if [ -f $WPAPID -o ! -f $WPACONF ]; then

            if [ ! -f $WPACONF ]; then
            に変更。

            14行目
            wpa_supplicant ….(省略)….
            の前に
            killall wpa_supplicant
            を追加。

            以上の2点の修正で、接続時に wpa_supplicant を終了するようになるはずです。
            ちなみに、上記修正は root 権限で行って下さい。

          • 身体を壊しては元もこの無いのでお気を付けて
            インフル怖いです

            自分も3000でそんな感じです
            レジュームすると、接続出来ているときもあるのですが、多くの場合は繋がった表示が出たまま内部的には繋がっていない…ような感じになっています。
            そのまま数分放っておくと接続出来ていないことに気付くようにして切断したりします。
            どの挙動にしても一貫性がないので何とも言えませんが。

            スプリクトの修正やってみました。
            再起動時に多重起動はなくなり接続はできるようになりましたが、Gatewayの所得が出来ていない?ようです。
            ゲートウェイがありません。と表示されます。
            AirStationのクライアントモニターでは、サスペンドしてから5分ほどは登録されていて、その後消えたため、これは切断時に切断しますよっていう情報が送られる前に電源が落ちるからかと思います。
            AirStationから情報が消える前に再接続すればLAN接続は保てるAirStationから情報が消えると再接続できなくなりました。
            AirStationに登録されている情報が消える前に再接続を試みた場合は、LAN内のみの接続となり、情報が消えた後では接続出来なくなりました。

            参考になりましたでしょうか?
            やはりドライバでサスペンド前に処理を入れる必要がありそうですね…

  15. はじめまして。
    Zaurus SL-C3000 を I・O DATA製 の WN-G54/CF で チャレンジしてますが、なんとかいじくりまわしてCFカードを認識させ、接続までできるようになったのですが、ネットにつなぐと「TCPコネクトエラー」と表示され、ネット接続できないんです。
    Zaurus本体は購入したままのノーマル状態で、あまり知識もありません。

    何かアドバイス頂けると嬉しいです。

     

    • 鹿28さん、返信が遅くなってごめんなさい。

      TCPコネクトエラーですが、私は見たこと無いんですよね・・・。
      ググってみると、NetFront で TCP コネクトエラーが出る状態でも、Opera では正常に表示できることもあるようですので、Opera を使ってみてはいかがでしょうか。

      Zaurus 用 Opera にはいくつかバージョンがありますが、初心者でも簡単に使える 7.25 がお勧めです。「zaurus opera 7.25」でググると必要なファイルや設定方法が詳しく書かれたページが見つかりますので、参考にしてみてください。

      • 少々仕事が忙しくってまだチャレンジできていませんが、今週中にはチャレンジしてみます。結果連絡しますので、もしNGだったら又良きアドバイスをお願いします。

  16. C1000でSSIDステルス有効のルータに繋いでいるのですが15分程で
    電波が弱くなっています と表示されます(すぐに再接続されるのですが
    WPA2/AESでの使用です。ドライバは最新、設定ソフトのSSIDステルスにもチェックをいれています。

    ルータ側で無効にすれば問題ないのですが原因わかりますでしょうか?

    • その現象は初耳ですね。
      SSIDステルスで使っていなかったので、私の環境でも確認してみます。
      ちょっと直せるかはわかりませんが・・・・。

  17. すばらしいドライバありがとうございます。
    ただ少し気になる点がありまして、私は起動パスワードを設定しているのですが、どうも復帰の際、しばらく無反応になってしまいます。
    CFの初期化回りが原因なんでしょうかね?

    もしよろしければ修正お願いします

    • うーん。なぜでしょうね・・・。
      無反応というのは、しばらくフリーズすると言うことでしょうか?
      外してるかもしれませんが、接続したままサスペンドしていませんか?
      接続したままのサスペンドはうまく動かなかった気がします。
      サスペンドする時に接続を切るようにしてみてください。

  18. CF型無線LANカードがほとんど在庫切れの中、こちらのドライバを頼りにアマゾンでWN-G54/CFを購入しましたが、本日マックにてBBモバイルポイントに接続できました。どうもありがとうございます。

    • あざらしサラダさん、こんにちは。
      返信遅くなってすいません。

      Amazon で確認してみたところ、まだ WN-G54/CF って手に入るんですね。ありがたいことです。
      まだまだかわいがってあげてくださいね。ご報告ありがとうございました。

コメントを残す

メールアドレスが公開されることはありません。

*