GW-CF54G ドライバの状況まとめ

正常動作しないと思っていた 3 桁機用のGW-CF54G ドライバですが、予期せず正常動作した方々がいらっしゃったので、私もいろいろいじった結果、正常動作させる条件が分かって来ました。

現在、正常動作が報告されている機種は以下のとおりです。

SL-C760では、素の状態に本ドライバをインストールすると先日のブログのような制限が発生しますが、先にシャープ製の CF-GW11X ドライバをインストールしておくと、正常動作するようです。

ただ、ここで注意するのはインストールの順番です。必ず、以下の順番でインストールしてください
すでに本ドライバがインストールされているときはアンインストールしてから、以下の順番でインストールし直してください。

  1. シャープ製 CF-GW11X ドライバ
  2. 本ドライバ

理由は、/etc/pcmcia/wlan-ng の修正がバッティングするためです。
本ドライバは、インストール時の上記ファイルを修正しますが、シャープ製ドライバはこのファイルを上書きしてしまうため、修正が消されてしまうためです。

同様の理由で、アンインストールの順番もインストールとは逆順で行わないと /etc/pcmcia/wlan-ng ファイルがオリジナルに戻らない可能性があります。

どうして CF-GW11X ドライバをインストールすると正常動作するのかはまだ分かっていませんが、可能であれば、本ドライバ単独のインストールで正常動作するように変更する予定です。

また、自分へのメモも兼ねて現在の制限事項をまとめて置きます。

  • 3桁機用
    • SL-C700では動作せず
    • 自動接続では接続できない
    • SL-C760 (SL-C750も同様?)では先にシャープ製 GW-CF11X ドライバを入れる必要がある
    • 接続中のサスペンド・レジュームの自動再接続ができない
    • インターネット接続設定アシスト非対応
  • 4桁機用
    • 接続中のサスペンド・レジュームの自動再接続ができない
    • 自動接続時に複数の設定にチェックが入っていると接続に時間がかかる
    • インターネット接続設定アシスト非対応
    • (検証中)本ドライバアンインストール後にGW-CF11Xドライバがインストールできない??

ぼちぼち修正していきます。

4 comments

  1. お世話になっております。私はSL-C860を使用しておりましてGW-CF54Gを標記の方法で試してみましたがカード自体に電源が入らず唯一作動した方法としては、CF-GW11Xドライバ→3 桁機用のGW-CF54G ドライバ→4 桁機用のGW-CF54G ドライバの順にインストールした場合で、ルーターまでは接続されるのですがそこからデータが降りてこず、通信が途切れてしまいます。どうぞご検討材料までにお知らせします。

    • はじめまして、竜馬様。

      SL-C860でも動作する/しないケースがあるということですね。
      まず、試したケースを教えていただけますか?

      ・CF-GW11Xドライバを入れずに本ドライバを入れて試した
       →動作しなかった
      ・CF-GW11Xドライバを入れて、本ドライバ(3桁機用)を入れて試した
       →動作しなかった
      ・CF-GW11Xドライバを入れて、本ドライバ(3桁機用、4桁機用)を入れて試した
       →アクセスポイントには接続できるようになった

      ということでしょうか。

      また、「カードに電源が入らない」時の様子(エラーメッセージ等)を教えてください。

      あと、4桁機ドライバを3桁機にはインストールするのは避けた方がいいです。
      4 桁機用のドライバは 3 桁機では動作しませんし、2つ同じドライバをインストールすることは想定していないので、アンインストールしても元に戻らなくなります。

      具体的には、/etc/pcmcia/wlan-ng がおかしくなるか、アンインストールに失敗する可能性もあります。

      インストールしたのと逆順にアンインストールして、エラーが出てアンインストールできないようでしたら、ご相談ください。

    • SL-C860では動かないとあきらめていたのですが、先日の記事でもう一度試してみました。
      3桁用ドライバーのみでは全然だめでした。
      シャープ製11ドライバー(一番おしりに”B”がついているやつ)をインストールし、再起動。その後3桁用ドライバーをインストールし、再起動。
      で一応接続出来そうになりましたが・・ESS-IDを設定しているとだめでESS-ID設定しないでやるとバッチリ接続できました。
      自動接続はどうもだめなようです。
      インターネットもOKですし、電界強度表示もきれいに出ます。
      この設定で11系のカードもそのまま動きました。
      ちなみに私のZaulusのファームは最新にアップしてあります。

      • はじめまして、daisuke 様。
        SL-C860 でも GW-CF11X ドライバを入れないと動かないということでしょうか。
        あと、ESSID 指定では繋がらないケースもあるということですね。

        うーん。動く人と動かない人何が違うんでしょうね・・・。

コメントを残す

メールアドレスが公開されることはありません。